left_info_block Anzeige Problem unter Produkt-Detailansicht

Ein Statischer CMS Block left_info_block (ich glaube eingebaut im MRG Market Ready German):

Mit folgender HTML-Codes:

….
<!–
<div>{{block type=”catalog/product_list” template=”catalog/product/popular_list.phtml” category_id=”104″}}</div>
–>

Der Block wird kein Problem auf der linken Seite unter allen Seiten außer Produktdetailseite angezeigt.

Lange Zeit gesucht, unter Layout, Themen, Vorlage wie 2Column-left und CMS-Block-Tabelle und auch Caching. Kein Erfolg. Durch Vergleich mit einen anderen gleichen Shop erkenne ich den kleinen Unterschied. Das die oben durch <!– –> auskommentierten Codes im funktionierenden Shop nicht auskommentiert.

Ich habe einfach dann die Stückchen Codes komplett gelöscht. Wird auch die resten jetzt richtig in meinem Shop angezeigt.

Es sollten keinen Konflikt zwischen die anderen Inhalte auf den Seiten geben. Wann die Block per toHtml() generiert wird, weiss das Programm noch nicht über die weiteren Inhalte. Höchstenwahrscheinlich ist, dass die Codes bei der Auswertung (Parser) zur Ausgabe einen Fehler verursacht, so dass HTML nicht generiert werden kann. Aber warum nur unter Produktdetailseite?

O.K. ein Hinweis. Wenn später ähnliches Phänome vorkommt, werde ich die Codes des Blocks noch reinigen.

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *


7 × = forty nine

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>